cs单机版

 找回密码
 账号注册
查看: 763|回复: 4

【包含源码】CS1.6登录器易语言源码+成品

[复制链接]
  • TA的每日心情
    擦汗
    2021-2-22 16:45
  • 195

    主题

    210

    帖子

    530

    积分

    高级会员

    Rank: 4

    积分
    530

    流量屠夫闪闪发光启明星讲师论坛元老荣誉管理突出贡献原创作者

    发表于 2021-3-8 13:14:37 | 显示全部楼层 |阅读模式
    本帖最后由 Boom 于 2021-3-8 13:18 编辑


    .版本 2
    .支持库 EThread
    .支持库 Exmlrpc
    .支持库 EXMLParser
    .支持库 dp1

    加载皮肤 (9)
    ' 加载Aero特效 ()
    ' Aero特效调整 (150, 200, 200, 200, 200, 200, 200)
    hInst = CreateMutex (0, 0, “MUTEX_MP_LAUNCHER”)
    .如果真 (GetLastError () = #ERROR_ALREADY_EXISTS)
        结束 ()
    .如果真结束
    编辑框1.内容 = 取文本注册项 (#现行用户, “Software\MetaProtect\username”, “”)
    编辑框2.内容 = 取文本注册项 (#现行用户, “Software\MetaProtect\password”, “”)
    .判断开始 (取文本注册项 (#现行用户, “Software\MetaProtect\savepwd”, “”) = “真”)
        选择框1.选中 = 真
    .默认
        选择框1.选中 = 假
    .判断结束
    写注册项 (#现行用户, “Software\MetaProtect\Connect”, “”)
    启动线程 (&连接服务器线程, , )
    用户登录状态 = 假

    .子程序 连接服务器线程, , , 解决同步导致登陆器启动慢的问题


    .如果 (客户端.连接 (63000, “60.206.69.250”, 假, &处理函数))
        标签4.文本颜色 = #绿色
        标签4.标题 = “连接服务器成功!”
    .否则
        标签4.文本颜色 = #红色
        标签4.标题 = “连接服务器失败!”

    .如果结束



    .子程序 处理函数
    .参数 消息地址, 整数型
    .局部变量 消息类型, 整数型
    .局部变量 结果消息, 字节集
    .局部变量 解密字串, 文本型
    .局部变量 分割数据, 文本型, , "0"
    .局部变量 数组成员计数, 整数型

    消息类型 = 客户端.取消息类型 (消息地址)
    .判断开始 (消息类型 = 0)
        信息框 (“与服务器连接断开!”, #错误图标, )
        结束 ()
    .判断 (消息类型 = 1)
        .如果真 (客户端.取返回文本 (消息地址, 解密字串))
            ' 解密字串 = 到文本 (解压数据 (结果消息))
            ' 输出调试文本 (解密字串)
            分割数据 = 分割文本 (解密字串, “|”, )
            数组成员计数 = 取数组成员数 (分割数据)
            ' 输出调试文本 (数组成员计数)
            .如果真 (数组成员计数 > 0)
                .判断开始 (分割数据 [1] = “#登陆成功”)
                    ' 输出调试文本 (解密字串)
                    用户登陆成功 (解密字串)
                .判断 (分割数据 [1] = “#下载资源”)
                    下载资源 (解密字串)
                .判断 (分割数据 [1] = “#服务器列表”)
                    设置服务器列表 (解密字串)
                    用户登录状态 = 真
                .判断 (分割数据 [1] = “#注册成功”)
                    注册成功 ()
                .判断 (分割数据 [1] = “#注册失败”)
                    信息框 (分割数据 [2], #错误图标, 分割数据 [1])
                .默认

                .判断结束

            .如果真结束

        .如果真结束

    .默认

    .判断结束


    .子程序 用户登陆成功
    .参数 解密字串, 文本型
    .局部变量 XML, XML树
    .局部变量 分割后数组, 文本型, , "0"
    .局部变量 XML数据, 文本型
    .局部变量 m_access, 文本型
    .局部变量 m_cnname, 文本型

    分割后数组 = 分割文本 (解密字串, “#登陆成功”, )
    .如果真 (取数组成员数 (分割后数组) = 2)
        XML数据 = 分割后数组 [2]
        .如果真 (XML.导入 (到字节集 (XML数据)))
            XML.取节点值 (“@1/@1”, m_access)
            XML.取节点值 (“@1/@2”, m_cnname)
            ' 信息框 (m_cnname, 0, )
            登录 = 真
            _用户登录成功 (编辑框1.内容, 编辑框2.内容, m_cnname, 到整数 (m_access))
            客户端.异步发送文本 (“#获取服务器列表|”)
        .如果真结束

    .如果真结束


    .子程序 设置服务器列表
    .参数 解密字串, 文本型
    .局部变量 XML, XML树
    .局部变量 分割后数组, 文本型, , "0"
    .局部变量 临时文本, 文本型
    .局部变量 XML数据, 文本型
    .局部变量 数据计数, 整数型
    .局部变量 循环计数, 整数型
    .局部变量 m_服务器列表, 服务器列表

    分割后数组 = 分割文本 (解密字串, “#服务器列表”, )
    .如果真 (取数组成员数 (分割后数组) = 2)
        XML数据 = 分割后数组 [2]
        .如果真 (XML.导入 (到字节集 (XML数据)))
            XML.取节点值 (“@1/@1”, 临时文本)
            数据计数 = 到整数 (临时文本)
            .计次循环首 (数据计数, 循环计数)
                XML.取节点值 (“@1/@” + 到文本 (循环计数 + 1) + “/@1”, m_服务器列表.显示名称)
                XML.取节点值 (“@1/@” + 到文本 (循环计数 + 1) + “/@2”, m_服务器列表.服务器IP)
                加入成员 (服务器列表, m_服务器列表)
                ' 输出调试文本 (m_服务器列表.显示名称 + “,” + m_服务器列表.服务器IP)
            .计次循环尾 ()
        .如果真结束

    .如果真结束


    .子程序 _用户登录成功
    .参数 账号, 文本型
    .参数 密码, 文本型
    .参数 中文名, 文本型
    .参数 权限, 整数型

    登录数据.中文名 = 中文名
    登录数据.密码 = 到小写 (取数据摘要 (到字节集 (密码)))
    登录数据.用户名 = 账号
    登录数据.权限 = 权限
    ' 用户登录状态 = 真

    .子程序 _时钟1_周期事件

    .如果真 (用户登录状态 = 真)
        写注册项 (#现行用户, “Software\MetaProtect\savepwd”, 到文本 (选择框1.选中))
        .如果 (选择框1.选中)
            写注册项 (#现行用户, “Software\MetaProtect\username”, 编辑框1.内容)
            写注册项 (#现行用户, “Software\MetaProtect\password”, 编辑框2.内容)
        .否则
            写注册项 (#现行用户, “Software\MetaProtect\username”, “”)
            写注册项 (#现行用户, “Software\MetaProtect\password”, “”)
        .如果结束

        载入 (窗口_主界面, , 假)
        _启动窗口.可视 = 假
        时钟1.时钟周期 = 0
    .如果真结束


    .子程序 _超级按钮1_被单击

    载入 (窗口_注册用户, , 真)

    .子程序 _按钮1_被单击

    .如果真 (编辑框1.内容 = “” 或 编辑框2.内容 = “”)
        信息框 (“用户名和密码不能为空!”, #错误图标, )
        返回 ()
    .如果真结束
    客户端.异步发送文本 (“#用户登录|” + 编辑框1.内容 + “|” + 取数据摘要 (到字节集 (编辑框2.内容)) + “|”)


    .子程序 _超级按钮2_被单击

    登录 = 假
    客户端.异步发送文本 (“#获取服务器列表|”)


    回复后可见
    游客,如果您要查看本帖隐藏内容请回复





    上一篇:来个大佬帮帮我
    CSOL单机版,游戏K2论坛,MOD中国同盟社,CF单机版,神器时代官方网站,csbte,cssme,ck竞技之王,创新纪元,破茧,超越,突破,cs地图,cs模型,cs插件,cs纹理,cskz,香蕉网,cs模型下载,CSOL大灾,CSOL大灾变单机版,EC精英社
    回复 论坛版权

    使用道具 举报

  • TA的每日心情
    开心
    2021-8-23 12:20
  • 46

    主题

    607

    帖子

    723

    积分

    高级会员

    【论坛积分排行榜NO.1】

    Rank: 4

    积分
    723

    原创作者活跃会员

    QQ

    狗飞飞 Lv:23
    发表于 2021-4-14 12:42:13 | 显示全部楼层
    154562156302256
    龙出海,虎下山,千百豪杰汇一处,争个功名觅风度,安敢止于现步
    回复

    使用道具 举报

  • TA的每日心情
    开心
    2021-7-20 11:57
  • 2

    主题

    8

    帖子

    11

    积分

    新手上路

    Rank: 1

    积分
    11
    发表于 2021-7-19 21:25:13 | 显示全部楼层
    6666666666666666666666666666666
    CSOL单机版,游戏K2论坛,MOD中国同盟社,CF单机版,神器时代官方网站,csbte,cssme,ck竞技之王,创新纪元,破茧,超越,突破,cs地图,cs模型,cs插件,cs纹理,cskz,香蕉网,cs模型下载,CSOL大灾,CSOL大灾变单机版,EC精英社
    回复

    使用道具 举报

  • TA的每日心情
    开心
    2021-8-15 22:16
  • 0

    主题

    9

    帖子

    22

    积分

    新手上路

    Rank: 1

    积分
    22
    发表于 2021-8-15 22:41:30 来自手机 | 显示全部楼层
    看看怎么样
    CSOL单机版,游戏K2论坛,MOD中国同盟社,CF单机版,神器时代官方网站,csbte,cssme,ck竞技之王,创新纪元,破茧,超越,突破,cs地图,cs模型,cs插件,cs纹理,cskz,香蕉网,cs模型下载,CSOL大灾,CSOL大灾变单机版,EC精英社
    回复

    使用道具 举报

  • TA的每日心情
    慵懒
    2021-8-19 13:18
  • 0

    主题

    16

    帖子

    17

    积分

    新手上路

    Rank: 1

    积分
    17
    发表于 2021-8-19 13:30:57 | 显示全部楼层
    2333333333333333333333333333333333333333333333
    CSOL单机版,游戏K2论坛,MOD中国同盟社,CF单机版,神器时代官方网站,csbte,cssme,ck竞技之王,创新纪元,破茧,超越,突破,cs地图,cs模型,cs插件,cs纹理,cskz,香蕉网,cs模型下载,CSOL大灾,CSOL大灾变单机版,EC精英社
    回复

    使用道具 举报

    懒得打字,不如试试右边的快捷回复→
    您需要登录后才可以回帖 登录 | 账号注册

    本版积分规则

    Archiver|手机版|小黑屋|csol单机版,神器时代官网,创.新纪元官网,csol单机版官网 |友链申请|网站地图

    GMT+8, 2021-10-19 12:37 , Processed in 0.266868 second(s), 41 queries .

    Powered by gamek2.com X3.4

    Copyright © 2001-2020, Tencent Cloud.

    快速回复 返回顶部 返回列表